Информатика. 8 класс

Урок 10. Алгоритмическая конструкция «повторение»

Установите соответствие между фрагментом блок-схемы и видом цикла, который она представляет.
Цикл с заданным числом повторений (Цикл ДЛЯ)
Цикл с условием продолжения работы (цикл ПОКА)
Цикл с условием окончания работы (Цикл ДО)

Исполнитель Робот в программной среде Пиктомир должен закрасить клетки квадратной площадки, на которой он находится.



Установите соответствие между элементами двух множеств.
Цикл ПОКА
нц пока <условие>
<тело цикла>
кц
Цикл ДЛЯ
нц для i от il до i2 шаг R
<тело цикла>
кц
Цикл ДО
нц
<тело_цикла>
кц при <условие>
Определите значение s после выполнения алгоритма.
алг
нач
цел s, k
s := 0
нц для k от 3 до 7
s := s + 6
кц
вывод s
кон
Ответ:
Определите особенности циклических алгоритмов.
Цикл имеет важную особенность, в нем тело цикла всегда выполняется хотя бы один раз, так как первая проверка условия происходит тогда, когда тело цикла уже выполнено.
Цикл проверяет условие до того как начнется выполняться тело цикла.
Цикл применяется в тех случаях, когда число повторений заранее известно.

Дана блок-схема алгоритма, определяющая кратность числа a трем.

Какое условие должно стоять вместо знака «?», чтобы алгоритм исполнялся верно?


X<=3

X>=3

X=3

X>3

Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии.

В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды: Вперёд n (где n — целое число), вызывающая передвижение Черепашки на n шагов в направлении движения; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке. Запись Повтори k [Команда1 Команда2 КомандаЗ] означает, что последовательность команд в скобках повторится k раз. Черепашке был дан для исполнения следующий алгоритм: Повтори 9 [Вперёд 70 Направо 90]. Какая фигура появится на экране?

правильный восьмиугольник

правильный четырёхугольник

правильный девятиугольник

незамкнутая ломаная линия

Иван увлекается математикой. Недавно на занятии кружка он узнал способ решения задачи о расчете разных вариантов распределения 5 разноцветных кружек в семье из пяти человек. Оказалось, что нужно посчитать произведение 1*2*3*4*5. По дороге домой Иван обдумывал составление алгоритма для решения такой же задачи с произвольным количеством обладателей кружек. Например, 300 для летнего лагеря или 2000 для большого отеля на берегу моря. Посоветуйте Ивану, каким видом цикла он может воспользоваться для решения своей задачи.

Только Циклом ДЛЯ

Только Циклом ДО

Для решения задачи подойдет любой вид цикла, надо только правильно сформулировать условие цикла

Эта задача не решается циклическими алгоритмами

Только Циклом ПОКА

Предметы

По алфавиту По предметным областям

Классы

1 2 3 4 5 6 7 8 9 10 11
angle-skew-bottom mix-copy next-copy-2 no-copy step-1 step-2 step-3 step-4 step-5 step-6 step-6 angle-skew-bottom mix-copy next-copy-2 no-copy step-1 step-2 step-3 step-4 step-5 step-6 step-6